Scheduled for April 02, 2025 at 2:00 PM – 5:18 PM
Completed
April 02, 2025 at 5:18 PMCompleted
April 02, 2025 at 5:18 PMThe scheduled maintenance has been completed.
In progress
April 02, 2025 at 2:00 PMIn progress
April 02, 2025 at 2:00 PMScheduled maintenance is currently in progress. We will provide updates as necessary.
Update
April 02, 2025 at 1:00 PMPlanned
April 02, 2025 at 1:00 PMMaintenance will begin as scheduled in 60 minutes.
Planned
March 26, 2025 at 4:15 PMPlanned
March 26, 2025 at 4:15 PMUI / Login Maintenance for the US2 Region - During this maintenance window, customers may experience intermittent outages to accessing login and see changes to the user interface of our products. Rest assured, backups, jobs and API usage will continue to run as scheduled.