Own from Salesforce - Investigating Incomplete Distribution of Weekly Report Emails – Incident details

Investigating Incomplete Distribution of Weekly Report Emails

Resolved
Major outage
Started 22 days agoLasted about 8 hours
Updates
  • Resolved
    Resolved

    This issue has been resolved. All pending weekly report emails have now been sent.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Update
    Update

    Some users may not have received their scheduled weekly report emails on Tuesday, August 5th 2025.

    We’re currently investigating an issue where scheduled weekly report emails were not sent as expected. Our team is actively working to identify the cause and resolve it. We’ll provide an update as soon as more information becomes available.

    We appreciate your patience and apologize for the inconvenience.

  • Investigating
    Investigating
    We are currently investigating this incident.