Own from Salesforce - Product UI degradation – Incident details

Product UI degradation

Resolved
Degraded performance
Started about 1 month agoLasted about 6 hours

Affected

HIPAA4

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

Backup & Recover

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

Archive

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

Data Mask & Seed

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

CA4

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

Backup & Recover

Degraded performance from 5:30 AM to 8:00 AM, Operational from 8:00 AM to 11:43 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Update
    UTC
    Update
    We are currently investigating this incident.
  • Investigating
    UTC
    Investigating

    Customers may currently experience disruptions to the user interface of our products. Backups, scheduled jobs, and API traffic are not impacted and continue to operate normally. We are actively working to restore the UI to full service and will provide updates as the situation progresses.