Own from Salesforce - Backup History File Download & Compare Job UI Loading are Failing in USEast2 – Incident details

Backup History File Download & Compare Job UI Loading are Failing in USEast2

Resolved
Degraded performance
Started 10 days agoLasted about 1 hour

Affected

USEAST2

Degraded performance from 4:20 PM to 5:30 PM

Backup & Recover

Degraded performance from 4:20 PM to 5:30 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    We identified an issue with our infrastructure provider, AWS, and are working to resolve the incident.

  • Investigating
    Investigating
    We are investigating an issue with file downloads from the backup history page in USEast2\.