Some Backups contain deleted records from Recycle bin - Salesforce data backup

Incident Report for Own from Salesforce

Resolved

The incident is now resolved and closed.
All Salesforce data backups that were affected by this incident are tagged 'Affected by Incident #124' as they include deleted Recycle Bin records. Please reach out to our support team if you need help restoring from any of these backups.
You can read more in this Knowledge Base Article: https://kb.ownbackup.com/articles/knowledgebase/Incident-124-30-11-2023.
Posted Dec 21, 2023 - 18:22 UTC

Update

All of your Salesforce data backups that were affected by this incident are tagged 'Affected by Incident #124' as they include deleted Recycle Bin records. Please reach out to our support team if you need help restoring from any of these backups.

You can read more in this Knowledge Base Article: https://kb.ownbackup.com/articles/knowledgebase/Incident-124-30-11-2023.
Posted Dec 04, 2023 - 16:29 UTC

Monitoring

A fix was deployed. It will take effect on your next Full backup.
We’re still investigating the impact on past affected backups.
Posted Nov 28, 2023 - 17:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 27, 2023 - 22:29 UTC

Investigating

We are investigating an issue with downloading attachments during Salesforce backups. Customers may experience increased errors in backups as a result. The errors can be seen in the backup history tab.
Posted Nov 27, 2023 - 20:05 UTC
This incident affected: App1 (Automatic Backups), HIPAA1 (Automatic Backups), EMEA1 (Automatic Backups), EMEA4 (Automatic Backups), CA1 (Automatic Backups), AU1 (Automatic Backups), USGOV2 (Automatic Backups), UK1 (Automatic Backups), HIPAA4 (Automatic Backups), EMEA2 (Automatic Backups), USeast2 (Automatic Backups), CA4 (Automatic Backups), and AU4 (Automatic Backups).