Backup Runtime Degradation

Incident Report for Own from Salesforce

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 16:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2025 - 11:18 UTC

Identified

We have implemented a workaround and are currently verifying the issue is resolved.
Posted Jun 07, 2025 - 08:39 UTC

Investigating

Some backups are taking longer than average to complete in this region. We are currently working on identifying the issue and a possible solution.
Posted Jun 07, 2025 - 07:46 UTC
This incident affected: USeast2 (Automatic Backups).