Accelerate is not accessible in AU4
Incident Report for Own Company
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 03:42 UTC
Investigating
We are currently investigation the issue.
Posted Apr 16, 2024 - 02:38 UTC
This incident affected: AU4 (User Access).