No access to user interface across all regions

Incident Report for Own from Salesforce

Resolved

This incident has been resolved.
Posted May 04, 2025 - 13:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted May 04, 2025 - 11:32 UTC

Identified

We have identified the root cause of this failure.
We are currently working on a fix
Posted May 04, 2025 - 09:28 UTC

Investigating

We are investigating an issue where users are unable to access the Own platform.
Posted May 04, 2025 - 09:12 UTC
This incident affected: App1 (User Access), HIPAA1 (User Access), EMEA1 (User Access), EMEA4 (User Access), CA1 (User Access), AU1 (User Access), USGOV2 (User Access), UK1 (User Access), HIPAA4 (User Access), EMEA2 (User Access), USeast2 (User Access), CA4 (User Access), AU4 (User Access), SG1 (User Access), and Unified Login.