Own from Salesforce - Logging in through 'auth.owndata.com' currently redirects to the wrong page. Please log in through 'app.owndata.com'. – Incident details

Logging in through 'auth.owndata.com' currently redirects to the wrong page. Please log in through 'app.owndata.com'.

Resolved
Partial outage
Started 4 months agoLasted 18 minutes

Affected

USGOV2

App1

HIPAA1

EMEA4

CA1

AU1

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this issue.