Own from Salesforce - US2 service disruption – Incident details

US2 service disruption

Resolved
Major outage
Started 17 days agoLasted about 10 hours

Affected

US2

Major outage from 2:30 AM to 12:15 PM

Backup & Recover

Major outage from 2:30 AM to 12:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We've identified the issue and are now working on restarting the failed backups.

  • Investigating
    Investigating

    We are currently investigating a condition where customers might experience pending or failed backups on US2 environment.